Page 1 sur 2 12 DernièreDernière
Affichage des résultats 1 à 10 sur 16

Discussion: Openmod et Bukkit

  1. #1
    Newbee
    Date d'inscription
    mars 2012
    Messages
    8

    Par défaut Openmod et Bukkit

    Bonjour,

    J'ai beau avoir cherché, je n'ai pas vraiment compris comment faire fonctionner bukkit et openmod simultanément.
    J'ai installé bukkit et openmod et je peux les faire marcher individuellement, mais pas moyen d'utiliser les deux en même temps.

    Merci d'avance

  2. #2
    Admin VeryGames
    Avatar de Adril
    Date d'inscription
    mai 2009
    Localisation
    Sur IRC : #verygames
    Messages
    6 535

    Par défaut

    C'est normal, c'est deux versions différente de ton serveur. OpenMod tu choisies le .jar que tu veux pour ton serveur. Craftbukkit c'est VeryGames qui gère la version que tu veux (avec le panel plugins lui aussi disponible).
    "Et alors ? On a bien envoyé des mecs sur la lune avec 4ko de ram" Maxence 'LinuTux' Poulain

  3. #3
    Newbee
    Date d'inscription
    mars 2012
    Messages
    8

    Par défaut

    Donc il n'y a pas moyen d'avoir des mods ainsi que des plugins?

  4. #4
    Sage Avatar de Nicko
    Date d'inscription
    décembre 2009
    Localisation
    Val d'Oise (95)
    Messages
    1 552

    Par défaut

    Il faut passez par open mod, installer la versions de bukkit que tu veut, que tu trouvera sur leurs site, et ensuite, installé t'es plugins manuellement.
    Mumble illimité, serveur pour tous.
    Adresses:
    mumble-5.verygames.net
    Port:
    50553

  5. #5
    Newbee
    Date d'inscription
    mars 2012
    Messages
    8

    Par défaut

    Non mais en fait j'ai mis et installé bukkit et openmod, mais vu qu'on ne peut lancer qu'un .jar à la fois, je ne peux pas avoir accès aux deux, et c'est justement là mon problème.

  6. #6
    Admin VeryGames
    Avatar de Adril
    Date d'inscription
    mai 2009
    Localisation
    Sur IRC : #verygames
    Messages
    6 535

    Par défaut

    Bonjour,

    en OpenMod tu peux lancer plusieurs .jar, il faut juste modifier la ligne de démarrage du serveur (onglet Mon serveur). La version Craftbukkit est gérer par VeryGames tu ne peux pas y toucher. En openMod c'est toi qui gère tout les .jar du serveur, les versions ect...

    Pour rappelle il y a peut de Mod qui supporte Craftbukkit en simultané.
    "Et alors ? On a bien envoyé des mecs sur la lune avec 4ko de ram" Maxence 'LinuTux' Poulain

  7. #7
    Newbee
    Date d'inscription
    mars 2012
    Messages
    8

    Par défaut

    Ce que je veux savoir en fait c'est comment lancer deux .jar, puisque la ligne de démarrage ne comporte qu'un emplacement dans les options de mon serveur.

  8. #8
    Admin VeryGames
    Avatar de Adril
    Date d'inscription
    mai 2009
    Localisation
    Sur IRC : #verygames
    Messages
    6 535

    Par défaut

    Il y a pourtant marqué en noir sur blanc : lire +INFO et donc si tu clics sur le petit bouton +info tu vois :

    En utilisant l'Openmod Java de VeryGames, vous avez la possibilité de personnaliser la ligne de lancement du serveur. Plus précisément les arguments "-cp" et "-jar".

    Cela vous permet de lancer des MODs Minecraft personnalisés (fichiers ".jar" que vous aurez préalablement envoyé par FTP dans le dossier /openmod/).

    Attention: Ne mettez PAS d'autres options Java dans le champ texte !
    Attention: Seuls les caractères suivants sont autorisés: "0-9 a-z A-Z [espace] _ : . /"

    Par défaut, la ligne de lancement est : "-jar minecraft_server.jar"

    Exemples:
    • "-cp", et argument "LE_MOD.jar:minecraft_server.jar"
    "Et alors ? On a bien envoyé des mecs sur la lune avec 4ko de ram" Maxence 'LinuTux' Poulain

  9. #9
    Newbee
    Date d'inscription
    mars 2012
    Messages
    8

    Par défaut

    Ok merci.

  10. #10
    Newbee
    Date d'inscription
    mars 2012
    Messages
    8

    Par défaut

    Donc en théorie je devrais entrer :

    bukkit.jar:minecraft_server.jar

    Mais cependant je ne parviens pas à faire marcher mon serveur ainsi (avec le minecraft_server.jar et bukkit.jar tout deux compatibles en 1.2.4 et sans mods installés).
    Je suppose que c'est une erreur bête de ma part, mais si ce n'est pas le cas, à quoi cela peut être du?

Page 1 sur 2 12 DernièreDernière

Informations de la discussion

Utilisateur(s) sur cette discussion

Il y a actuellement 1 utilisateur(s) naviguant sur cette discussion. (0 utilisateur(s) et 1 invité(s))

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •