Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
News ticker
  • Bienvenue sur le nouveau forum VeryGames
  • Welcome to the new VeryGames forum
  • VeryNews

    problème server UT3


    TRUQUE
     Share

    Recommended Posts

    Bonjour à tous je suis nouveau sur ce forum j'espère avoir quelques solution de votre part pour certain de mes problème

     

    voilà j'ai décidé de créer un serveur UT3 j'ai suivi de le tuto de verywiki et le serveur ce lance plus ou moin bien c'est a dire que j'arrive à voir mon serveur en lan mais je ne peux pas m y connecter d'autant plus que j'ai regardé les infos du serveur et sur adresse IP il n y a rien et en serveur Engine ça me marque 0 alors que c'est la version 3808 que j'ai dans tout les cas il devrait y avoir quelque chôse que 0

     

    donc je pense plus a un problème de configuration mais j'ai essayé plus métode et rien a y faire j'ai fait le compte gamespy avec le fichier cfg

     

    est ce que ce fichier CFG est diréctement détecté par le server ou faut-il créer une ligne sur un fichier pour qu'il soit pris en compte ?

     

    j'ai ouver le port 25000 pour ce server et j'ai bien mis 25000 sur le fichier UTEngine.ini est ce que ce port nuirait pour le server ?

     

    j'espère avoir plusieur solution merci d'avance :)

    Link to comment
    Share on other sites

    Bonsoir,

     

    Pourriez-vous nous communiquer l'ip de votre serveur afin que je puisse également tenter une connexion ainsi qu'un ping des informations de celui-ci?

    Par ailleurs, lorsque vous précisez "En lan", il s'agirait donc de votre ordinateur et non d'un serveur VeryGames?

     

    Cordialement, Cybernatus.

    Link to comment
    Share on other sites

    l'adresse ip est 88.173.195.85:25000 le serveur n'est pas un verygame c'est un serveur que j'ai créé moi même j'ai essayé avec un pote il a réussi a ce connecter sur mon serveur mais obligé d'inscrire l'addresse ip que ce soit local ou adresse ip public quand je suis dans l'interface raseauLan je vois mon serveur mais je ne vois pas mon adresse ip ni la version du moteur du serveur et sur internet y a carrément rien

     

    le server tourne sous linux avec un processeur AMD Athlon64 3400+ 2Go DDR 400 et deux petit disque dur mais bon la config n'est pas un problème que j'ai réussi a faire des partie sans aucun souci

    Edited by TRUQUE
    Link to comment
    Share on other sites

    Bonsoir,

     

    De mon coté votre serveur ne répond pas (Ou peut-être est-il simplement éteint). Par ailleurs, j'ai beaucoup de mal à cerner ce passage :

     

    il a réussi a ce connecter sur mon serveur mais obligé d'inscrire l'addresse ip que ce soit local ou adresse ip public

     

    Me concernant, il est bien entendu nécessaire d'introduire une adresse IP afin de joindre votre serveur et je ne comprend pas le rapport avec une IP local. La chose la plus importante est de s'assurer que votre routeur dirige les connexions entrantes des ports 25000 TCP & 25010 UDP vers votre ordinateur. Celui-ci doit d'ailleurs être dépourvu de pare-feu pour en assurer sa bonne mise en ligne.

     

    Si votre routeur possède la fonction DMZ (Zone démilitarisée), essayez de temporairement l'activer sur votre IP local afin d'être sûr des résultats obtenus.

     

    Aussi, utilisez-vous Ubuntu afin de lancer votre serveur? Je pourrais dés lors vous aidez d'avantage et vous fournir des scripts de démarrage et de gestions pour celui-ci dans la mesure du possible.

     

    Cordialement, Cybernatus.

    Link to comment
    Share on other sites

    oui il à réussi a ce connecter sur mon serveur mais pas en naviguant sur l'interface de recherche de serveur uniquement en inscrivant l'adresse IP les ports sont bien débloqué ma ligne de command est ./ut3 server ?NumPlay=16?MaxPlayers=16?TimeLimit=20?BotSkill=2?ForceRespawn=1 -nohomedir

     

    j'ai tenté de mettre -multihome=88.173.195.85 mais le server plante dès que je fais cette manipe si je fais bIsLanMatch=true plus multihome, sur l'interface LAN je ne retrouve plus mon serveur j'enlève la fonction multihome je retrouve mon serveur sur l'interface Lan y a de quoi ce cassé la tête ¿ :s

     

    le serveur est en route pour le moment toujours 88.173.195.85:25000 la carte c'est DM-Deck

     

    ---------- Post added at 02h43 ---------- Previous post was at 02h32 ----------

     

    par contre est-il nécessaire d'ouvrire les port TCP pour UT3 sachant que pour UT2004 je n'ai ouvert que le port UDP et cela fonctionne

    Edited by TRUQUE
    Link to comment
    Share on other sites

    Bonsoir,

     

    Je pense que dans la situation actuelle, mieux vaut ne rien négliger afin d'être sûr d'obtenir des résultats convaincants. C'est pourquoi je vous invite à bien libérer les ports dans les 2 sens TCP/UDP ou si possible activer temporairement la DMZ ce qui serait un must pour les connexions entrantes.

     

    Me concernant, votre serveur ne répond toujours pas tout comme hier et ce, qu'il soit en ping UDP ou en connexion direct. Afin de vous aidez, je vais également lancer une instance local de UT3 sous Ubuntu afin de mieux comprendre son fonctionnement sous cet OS et n'hésiterai pas à vous en communiquer les résultats si votre problème n'est pas réglé d'ici-là.

     

    Cordialement, Cybernatus.

    Link to comment
    Share on other sites

    Bonsoir

     

    je n'ai aucune idée de sque c'est le DMZ mais je n'ai pas d'option pour l'activé ou désactivé tout sque je sais c'est qui'il est sur 192.168.0.0 a la fin, a quoi sa sers ?

     

    les port de UT3 en TCP et UDP par défaults sont les quels ?

     

    mes collègues on pu ce connecter mais toujours en inscrivant l'ip dans le jeu multijoueur rejoindre partie et inscriptionIP

    Link to comment
    Share on other sites

    2028048906_UT32010-05-1822-2amp.thumb.jpg.b0b9dd0bc3553effaf0d7e46a8721f95.jpg

     

    voilà un petit screenshot je suis en partie LAN je vois bien mon serveur mais sur server IP je n'ai rien et sur engine version je n'ai rien et si je tente de me connecter sa m'affiche connexion mais rien ne ce passe

    Link to comment
    Share on other sites

    • 3 weeks later...

    bonjouur me revoilà mais toujours même souci

     

    jme suis demandé si c'était possible d'avoir des fichier .ini aisi que le gamespy.cfg d'un serveur bien configuré voir si ça correspond bien à ma configuration ou si j'ai fais une faute à quelque part

     

    j'espere avoir une réponse :) merci d'avance

     

    ---------- Post added at 13h44 ---------- Previous post was at 12h48 ----------

     

    voilà jvous donne squ'il y a d'inscrit après ma command

     

    Init: Version: 3808

    Init: Epic Internal: 0

    Init: Compiled: Apr 22 2009 04:27:51

    Init: Command line: server DM-Deck?NumPlay=16?MaxPlayers=16?BotSkill=1?bIsDedicated=true?bIsLanMatch=true -multihome=88.173.195.85 -login=truque1@hotmail.com -password=080189 -nohomedir -unattended

    Init: Base directory: /home/truque/serveur/Jeux/UT3/Binaries/

    Init: Character set: Unicode

    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTEditor.ini

    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTEditorUserSettings.ini

    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTEngine.ini

    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTGame.ini

    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTInput.ini

    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTUI.ini

    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTMapLists.ini

    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTVote.ini

    Init: File handle limit is soft=(1024), hard=(1024).

    Init: Computer: unknown

    Init: User: truque

    Init: BSD Sockets initialized

    Init: Presizing for 83221 objects not considered by GC, pre-allocating 0 bytes.

    Init: Object subsystem initialized

    Init: Startup System Settings:

    Init: System Settings:

    Init: StaticDecals=true

    Init: DynamicDecals=true

    Init: DynamicLights=true

    Init: DynamicShadows=true

    Init: LightEnvironmentShadows=true

    Init: CompositeDynamicLights=false

    Init: DirectionalLightmaps=true

    Init: MotionBlur=false

    Init: DepthOfField=true

    Init: Bloom=true

    Init: QualityBloom=true

    Init: Distortion=true

    Init: DropParticleDistortion=false

    Init: SpeedTreeLeaves=true

    Init: SpeedTreeFronds=true

    Init: OnlyStreamInTextures=false

    Init: LensFlares=true

    Init: FogVolumes=true

    Init: FloatingPointRenderTargets=true

    Init: Trilinear=false

    Init: OneFrameThreadLag=true

    Init: UseVsync=false

    Init: UpscaleScreenPercentage=true

    Init: Fullscreen=false

    Init: AllowD3D10=true

    Init: EnableHighPolyChars=false

    Init: SkeletalMeshLODBias=0

    Init: ParticleLODBias=0

    Init: DetailMode=2

    Init: ShadowFilterQualityBias=0

    Init: MaxAnisotropy=4

    Init: MaxMultisamples=1

    Init: MinShadowResolution=32

    Init: MaxShadowResolution=512

    Init: ResX=800

    Init: ResY=600

    Init: ScreenPercentage=100.000

    Init: SceneCaptureStreamingMultiplier=1.000

    Init: FoliageDrawRadiusMultiplier=1.000

    Init: ShadowTexelsPerPixel=2.000

    Log: TEXTUREGROUP_World: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_WorldNormalMap: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_WorldSpecular: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_Character: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_CharacterNormalMap: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_CharacterSpecular: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_Weapon: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_WeaponNormalMap: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_WeaponSpecular: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_Vehicle: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_VehicleNormalMap: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_VehicleSpecular: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_Effects: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_Skybox: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_UI: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_LightAndShadowMap: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Log: TEXTUREGROUP_RenderTarget: (MinLODSize= 1,MaxLODSize=4096,LODBias=0)

    Init: Friendly System Settings:

    Init: TextureDetail=Level5

    Init: WorldDetail=Level5

    Init: bUseVSync=0

    Init: bUseMSAA=0

    Init: ScreenPercentage=100

    Init: UpscaleScreenPercentage=1

    Init: ResX= 800

    Init: ResY= 600

    Init: Fullscreen=0

    Init: AllowMotionBlur=0

    Log: Initializing FaceFX...

    Log: FaceFX initialized:

    Log: version 1.710000

    Log: licensee Unreal Engine 3 Licensee

    Log: project Unreal Engine 3 Project

    Log: GConfig::Find has loaded file: ..\Engine\Localization/int/Core.int

    Log: GConfig::Find has loaded file: ..\Engine\Localization/int/Engine.int

    Log: Loaded shader cache RefShaderCache-PC-D3D-SM3.CacheObject: 27892 shaders(2 legacy, 0 redundant), 2950 materials

    Log: GConfig::Find has loaded file: ..\Engine\Localization/int/UnrealScriptTest.int

    Log: GConfig::Find has loaded file: ..\UTGame\Localization/int/UTGame.int

    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTWeapon.ini

    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTCustomChar.ini

    Log: GConfig::LoadFile associated file: ../UTGame/Config/UTMap.ini

    Log: GConfig::LoadFile has loaded file: ../UTGame/Config/UTWeb.ini

    Log: GConfig::Find has loaded file: ..\Engine\Localization/int/OnlineSubsystemGameSpy.int

    Log: GConfig::Find has loaded file: ..\UTGame\Localization/int/UTGameContent.int

    Init: Version: 3808

    Init: Epic Internal: 0

    Init: Compiled: Apr 22 2009 04:34:47

    Init: Command line: DM-Deck?NumPlay=16?MaxPlayers=16?BotSkill=1?bIsDedicated=true?bIsLanMatch=true -multihome=88.173.195.85 -login=truque1@hotmail.com -password=080189 -nohomedir -unattended

    Init: Base directory: /home/truque/serveur/Jeux/UT3/Binaries/

    Init: Character set: Unicode

    Log: Executing Class Engine.ServerCommandlet

    Log: Initializing Game Engine...

    Init: UEngine initialized

    Log: Looking for DLC...

    Log: Object size..............: 60

    Log: Actor size...............: 436

    Log: ActorComponent size......: 88

    Log: PrimitiveComponent size..: 448

    Log: GConfig::Find has loaded file: ../UTGame/Config/UTUIDataStore_Registry_0.ini

    Log: GConfig::Find has loaded file: ../UTGame/Config/UTWebAdmin.ini

    Log: GConfig::Find has loaded file: ../UTGame/Config/GameSpy.ini

    Log: Performing DNS lookup for stunserver.org

    Log: Browse: DM-Deck?Name=Player?team=255?NumPlay=16?MaxPlayers=16?BotSkill=1?bIsDedicated=true?bIsLanMatch=true

    Log: Award progress has now been fully reenabled!

    Log: LoadMap: DM-Deck?Name=Player?team=255?NumPlay=16?MaxPlayers=16?BotSkill=1?bIsDedicated=true?bIsLanMatch=true

    Log: Game class is 'UTDeathmatch'

    Init: Sockets: Socket queue 262142 / 262142

    Log: Failed to listen: Sockets: binding to port 7777 failed (99)

    Error: Error initializing network layer.

    Log: Primary PhysX scene will be in software.

    Log: Creating Primary PhysX Scene.

    Log: Bringing World DM-Deck.TheWorld up for play (0) at 2010.12.19-16.01.14

    ScriptLog: Current map is not the maplist's active map, updating maplist

    ScriptLog: Destroying WebServer

    Log: Bringing up level for play took: 0.657768

    Log: ########### Finished loading level: 2.082351 seconds

    Init: Game engine initialized

    Log: Initializing Game Engine Completed

    Log: FSTUNClient resolved stunserver.org (132.177.123.13)

    Log: FSTUNClient starting test 1...

    ScriptLog: Cerberus CustomChar - Load Assets: KRAM

    Log: Begin Async loading packages for Family 'KRAM':

    Log: - CH_Krall_Male

    Log: Flushing async loaders.

    Log: Family Asset Package Loaded: CH_Krall_Male_SF

    Log: CONSTRUCTIONING: LoadFamilyAsset (KRAM) Took: 59.38 secs

    ScriptLog: CUSTOMCHAR Start: UTPlayerReplicationInfo_0 Cerberus TeamSkin: V01

    Log: StartCustomCharMerge: 0.131013 ms initializing, 0.505987 ms texture streaming

    Log: Performing DNS lookup for stun.xten.com

    Log: FSTUNClient resolved stun.xten.com (75.101.138.128)

    Log: FSTUNClient starting test 1...

    Log: FSTUNClient test complete, NAT is open.

    Error: Can't start an online game that hasn't been created

    ScriptLog: START MATCH

    ScriptLog: TIMEOUT: Streaming Textures for custom char. UTPlayerReplicationInfo_0

    ScriptLog: CUSTOMCHAR Start: UTPlayerReplicationInfo_4 Scorn TeamSkin: V01

    Log: StartCustomCharMerge: 0.102909 ms initializing, 1.289091 ms texture streaming

    ScriptLog: TIMEOUT: Streaming Textures for custom char. UTPlayerReplicationInfo_4

    ScriptLog: CUSTOMCHAR Start: UTPlayerReplicationInfo_6 Hellhound TeamSkin: V01

    Log: StartCustomCharMerge: 0.112038 ms initializing, 0.490962 ms texture streaming

    Exit: closesocket error (11)

    Exit: UTcpNetDriver shut down

    ScriptLog: TIMEOUT: Streaming Textures for custom char. UTPlayerReplicationInfo_6

    ScriptLog: Kira CustomChar - Load Assets: TWIF

    Log: Begin Async loading packages for Family 'TWIF':

    Log: - CH_RTeam_Female

    Log: - CH_RTeam_Female2

    Log: Flushing async loaders.

    Log: Family Asset Package Loaded: CH_RTeam_Female_SF

    Log: Family Asset Package Loaded: CH_RTeam_Female2_SF

    Log: CONSTRUCTIONING: LoadFamilyAsset (TWIF) Took: -38.14 secs

    ScriptLog: CUSTOMCHAR Start: UTPlayerReplicationInfo_1 Kira TeamSkin: V01

    Log: StartCustomCharMerge: 0.095984 ms initializing, 0.889016 ms texture streaming

    ScriptLog: TIMEOUT: Streaming Textures for custom char. UTPlayerReplicationInfo_1

    ScriptLog: Evolution CustomChar - Load Assets: LIAM

    Log: Begin Async loading packages for Family 'LIAM':

    Log: - CH_Corrupt_Male

    Log: - CH_Corrupt_Male2

    Log: Flushing async loaders.

    Log: Family Asset Package Loaded: CH_Corrupt_Male_SF

    Log: Family Asset Package Loaded: CH_Corrupt_Male2_SF

    Log: CONSTRUCTIONING: LoadFamilyAsset (LIAM) Took: -27.66 secs

    ScriptLog: CUSTOMCHAR Start: UTPlayerReplicationInfo_2 Evolution TeamSkin: V01

    Log: StartCustomCharMerge: 0.228961 ms initializing, 0.814039 ms texture streaming

    ScriptLog: TIMEOUT: Streaming Textures for custom char. UTPlayerReplicationInfo_2

    ScriptLog: CUSTOMCHAR Start: UTPlayerReplicationInfo_7 Nova TeamSkin: V01

    Log: StartCustomCharMerge: 0.125923 ms initializing, 0.511077 ms texture streaming

    ScriptLog: TIMEOUT: Streaming Textures for custom char. UTPlayerReplicationInfo_7

    ScriptLog: CUSTOMCHAR Start: UTPlayerReplicationInfo_9 Mihr TeamSkin: V01

    Log: StartCustomCharMerge: 0.117986 ms initializing, 0.521014 ms texture streaming

    ScriptLog: TIMEOUT: Streaming Textures for custom char. UTPlayerReplicationInfo_9

    ScriptLog: Kragoth CustomChar - Load Assets: NECM

    Log: Begin Async loading packages for Family 'NECM':

    Log: - CH_Necris_Male1

    Log: Flushing async loaders.

    Log: Family Asset Package Loaded: CH_Necris_Male1_SF

    Log: CONSTRUCTIONING: LoadFamilyAsset (NECM) Took: 2.72 secs

    ScriptLog: CUSTOMCHAR Start: UTPlayerReplicationInfo_3 Kragoth TeamSkin: V01

    Log: StartCustomCharMerge: 0.240922 ms initializing, 0.917078 ms texture streaming

    Signal: SIGSEGV [segmentation fault]

    Aborting.

    Log:

    Developer Backtrace:

    Log: [ 1] ./ut3-bin() [0x8db9772]

    Log: [ 2] [0xb78ca400]

    Log: [ 3] ./ut3-bin() [0x8200d52]

    Log: [ 4] ./ut3-bin() [0x80ad258]

    Log: [ 5] ./ut3-bin() [0x8d0d837]

    Log: [ 6] ./ut3-bin() [0x8d0dce4]

    Log: [ 7] ./ut3-bin() [0x8d17fac]

    Log: [ 8] ./ut3-bin() [0x8d0a3d4]

    Log: [ 9] ./ut3-bin() [0x8cfbaba]

    Log: [10] ./ut3-bin() [0x8d0da03]

    Log: [11] ./ut3-bin() [0x8d0dd35]

    Log: [12] ./ut3-bin() [0x8d0a3d4]

    Log: [13] ./ut3-bin() [0x8cfbaba]

    Log: [14] ./ut3-bin() [0x8d0d2dd]

    Log: [15] ./ut3-bin() [0x8576536]

    Log: [16] ./ut3-bin() [0x8577d05]

    Log: [17] ./ut3-bin() [0x857715b]

    Log: [18] ./ut3-bin() [0x857c485]

    Log: [19] ./ut3-bin() [0x857aaca]

    Log: [20] ./ut3-bin() [0x850e702]

    Log: [21] ./ut3-bin() [0x8487460]

    Log: [22] ./ut3-bin() [0x80532c2]

    Log: [23] ./ut3-bin() [0x804b945]

    Log: [24] /lib/i686/cmov/libc.so.6(__libc_start_main+0xe6) [0xb7743c76]

    Log: [25] ./ut3-bin() [0x804af81]

    Crash information will be saved to your logfile.

    Exit: Exiting.

    Exit: Name subsystem shutting down

    Edited by TRUQUE
    Link to comment
    Share on other sites

    • 3 months later...

    me revoilà j'espère avoir une réponse depuis le temps que jsuis bloqué

     

    j'ai réussi a me connecter en réseau local mais le problème est que je n'ai toujours pas d'info au niveau de l'addresse et de l'engine qui indique 0 comme sur les screens que j'avais envoyé

     

    sinon d'ai réessayé de faire des manip et j'ai vu que le port 7777 est "bloqué" alors que sur mon router il est bien débloqué sur la bonne addresse bien sur

     

    j'ai décidé de tente sur windows pour voir si il y aurait une différence mais pas du tout j'en reviens éxactement au même point donc voilà je n'ai plus d'idée pour ma part jvais continuer de regarder mais j'espère vraiment avoir une réponse

     

    merci d'avance

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...