Jump to content
News ticker
  • Bienvenue sur le nouveau forum VeryGames
  • Welcome to the new VeryGames forum
  • VeryNews

    [urgent]Soucis au niveau des plugins.


    Mira
     Share

    Recommended Posts

    Bonjour à tous,

     

    Je dispose d'un serveur ffa mais il y à un problème quand j'ajoute des cvars dans mon server.cfg cela ne marche pas. Le plugin est "unknow" dans la pause list des plugins. Alors que je place bien les fichiers .amxx et .sma et je les déclares dans le plugins.ini

     

    Voici ci-joint mon server.cfg :

     

    # load ban files

    exec listip.cfg

    exec banned.cfg

    heartbeat

    ####################################

    # basic MATCH server configuration #

    ####################################

    sv_password ""

    rcon_password "tu rêve ma poule"

     

    hostname "FR- !Demons! # FFA [Enjoy]"

     

    fps_max 1000

    mp_friendlyfire 0

    mp_timelimit 80

    mp_freezetime 4

    mp_c4timer 35

    mp_autoteambalance 0

    mp_limitteams 0

    mp_roundtime 3.50

    mp_buytime 0.5

    sv_cheats 0

    sv_aim 0

    sv_maxspeed 320

    pausable 0

    sv_maxrate 0

    sv_minrate 10000

    sv_maxupdaterate 101

    sv_minupdaterate 20

    # Serveur HTTP pour download des maps, des sons...

    # Vous pouvez y ajouter vos maps et sons en demandant sur le forum VeryGames

    # HTTP server for maps and sounds downloads

    # Your can add your own files on it, by asking on VeryGames forum.

    sv_downloadurl "http://maps.verygames.net/halflife/cstrike"

    # requis pour psychostats

    # required for psychostats

    log on

    mp_logfile 1

    # NE PAS MODIFIER

    # DON'T MODIFY

    sv_stats 0

     

    Ou esque je dois exactement mettre les cvar svp? Car j'ai essayé en plein millieu, au début, à la fin..

    Link to comment
    Share on other sites

    bonjour

     

    a partir du moment ou le plugin est "unknown" comme tu dis c'est qu'il y a un soucis à l'installation.

    des fois un reboot du serveur suffit, d'autres fois il faut réinstaller ton plugin.

    tu peux aussi essayer en le recompillant .

     

     

    pour les cvars mets les a la fin de ton "server.cfg" c'est plus facile a retrouver si tu veux modifier.

     

    personnellement pour les plugins de base je modifies directement dans le .sma et je recompille cela evite d'en rajouter de trop dans le "server.cfg" (high ping etc......)

    Link to comment
    Share on other sites

    bonjour,

     

    pourtant je place bien mes fichiers .amxx dans plugins et mes .sma dans scriptings, puis je vais dans plugins.ini déclaré mes plugins. Pourtant, certains marchent, mais par exemple le bullet damage et l'admin chat colors ne marchent pas. Dans mon server.cfg le problème viens sûrement d'ici car je ne sais pas d'ou cela peut venir.

    Link to comment
    Share on other sites

    on ne prend personne pour des jambons mais faudrait aussi arreter de venir pleurer qu'on ne vous donne pas de réponse quand vous ne fournissez pas les infos minimum

     

    tu as un plugin qui ne fonctionne pas alors donne nous le lien de ton plugin pour que l'on puisse verifier nous aussi.

    precise aussi si tu es sur amx2006 ou AMXMODX (bah oui c'est improtant)

     

    quand tu nous donnes ceci

    pourtant je place bien mes fichiers .amxx dans plugins et mes .sma dans scriptings, puis je vais dans plugins.ini déclaré mes plugins. Pourtant, certains marchent, mais par exemple le bullet damage et l'admin chat colors ne marchent pas. Dans mon server.cfg le problème viens sûrement d'ici car je ne sais pas d'ou cela peut venir.
    nul part il est écrit que tu change de map ou que tu reboot ton serveur. En plus ce sont 2 plugins qui fonctionnent parfaitement sur plein de serveursdonc soit tu as loupé un truc soit tu en as loupé 2.

     

    Peu etre aussi que tu n'a recompiler ton plugin que sur le site amxmodx et par sur le lien fournis par cagnois (et oui ca a son importance aussi)

     

    Alors arrete de pleurer un peu et donnes nous les infos qu'il nous manque si tu veux une réponse.

    Link to comment
    Share on other sites

    bonjour,

    non toujours pas mais par contre je viens d'essayé quelque chose (qui n'a sûrement rien à voir)

    quand je met mon gamenamechanger tout va bien, mais dès que je met l'admin chat colors, pouf unknow.

    L'admin chat color ne passe pas sur le serveur, j'ai déjà recrée le serveur sur ma machine, compilé le .sma et remplacé.

     

    Mais si je met les cvar autre que dans le server.cfg par exemple cvar.ini cela change quelque chose ?

    Link to comment
    Share on other sites

    Bonjour,

     

    Pour le plugin admin chat color vous avez soit celui la : http://verywiki.net/fr/Admin_chat_colors ou celui la : http://forums.alliedmods.net/showthread.php?t=56825

    Tous les 2 fonctionnent.

     

    Pour les cvars il faut les mettre sur votre server.cfg

    Le fichier cvars.ini sert uniqmene a changer les cvars par defaut du server

     

    oui je vais essayé sur cz une fois on verra bien en tout cas merci j'éditerai si ca ne marche pas

     

     

    cela ne marche pas et j'ai essayé avec le allchat, quand je veux l'up il me dis qu'il y à 22 erreurs.

     

    Voici ce qu'il me dis :

     

    /tmp/text6rwjVw.sma(1) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(5) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(7) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(9) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(13) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(16) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(21) : error 020: invalid symbol name "Cvars"

    /tmp/text6rwjVw.sma(24) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(29) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(35) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(39) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(44) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(45) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(47) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(51) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(54) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(58) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(62) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(65) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(72) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(75) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(80) : error 010: invalid function or declaration

    /tmp/text6rwjVw.sma(226) : warning 203: symbol is never used: "Copyright"

    /tmp/text6rwjVw.sma(226) : warning 203: symbol is never used: "Ian"

     

     

    J'ai du le faire manuellement, mais cela ne marche pas, quand je veux mettre le fichier même, il me dis d'up un fichier valide.

    /tmp/text6rwjVw.sma(226) : warning 203: symbol is never used: "Key"

    Edited by Mira
    =)
    Link to comment
    Share on other sites

    • 2 weeks later...

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...