Jump to content
News ticker
  • Bienvenue sur le nouveau forum VeryGames
  • Welcome to the new VeryGames forum
  • VeryNews

    [Installer un mod] Problème avec Mo creature


    Solaart

    Recommended Posts

    Bonjour, cela fait quelques heures que j'essaye d'installer le mod Mo creature sur mon serveur, sans résultat !

     

    J'ai pourtant réussi à installer le mod Buildcraft, mais pour Mo' creature aucun moyen de l'installer, Pourtant il est indiqué dans la faq du thread officiel sur le forum minecraft, que ce mod est compatible avec le SMP

     

    Q.: Does this work for SMP?

    A.: Using itemcraft, you can play this mod for multiplayer

     

    Que faire ? (

    Edited by Solaart
    Link to comment
    Share on other sites

    En solo j'ai installé Audiomod, ModloaderMP, moadloader, GUI Api et ensuite le mod Mo'creature, (il fonctionne parfaitement en solo)

    Pour ce qui est du multijoueur j'ai installé Itemcraft.jar et craftbukkit-0.0.1-SNAPSHOT.jar sur mon ftp, j'ai du généré un dossier "itemcraft" en local que j'ai ensuite envoyer sur mon ftp, il contient "ICPuglings" (avec le mod "ICMoCreatures.jar) et "Icscripts" qui permet de sélectionner le mod que je veux exécuter .

     

    Je pense que le problème vient de l'installation d'itemcraft en local, verygames propose un tutoriel pour l'installer en multi, mais pas en local, alors je ne sais pas quoi faire /:

    Link to comment
    Share on other sites

    Tu l'utilises sur un serveur local ? Dans tous les cas, il faut que tu changes la ligne de commande qui permet de lancer ton serveur en reprenant la même que celle du tuto sur VG (Chage juste le : en ; si tu es sous Windows) et le principe reste le même.

    Link to comment
    Share on other sites

    Voilà j'ai donc installer Modloader, ModloaderMp et 16bitentitymod pour le coté client.

     

    J'ai ensuite suivi le tutoriel de verygames

     

    Coté serveur

    1. Stopper le serveur



    2. Pour commencer télécharger le pack

      Itemcraft ici


    3. Dans le dossier itemcraft puis serveur, Placer les deux fichiers .jar dans : /games/minecraft/openmod de votre serveur via le FTP.


    4. Ensuite sur votre panel dans Mon serveur chercher Personnaliser la ligne de commande et entrer :


    Dans la petite case choisir -cp

    Code:

     

    ItemCraft.jar:craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main

    Pour finir Démarrer le serveur

     

     

    Maintenant, comment faire pour installer Mo Creature ?

     

    EDIT : je ne peux me connecter au serveur, il reste figé sur "Logging in" J'ai pourtant suivis le tuto à la règle..

    Edited by Solaart
    Link to comment
    Share on other sites

    Pour installer Mo'Creatures côté serveur, tu vas le télécharger ici : Mo' Creatures.

    Ensuite, tu mets le fichier jar dans ton dossier ICPlugins (Dans le dossier Itemcraft) et tu relances ton serveur.

     

    Attention en revanche car il y a encore pas mal de bug dans ce plugin. Le mec qui bosse dessus les corrige au fil des jours mais pour le moment, il n'y a grosso modo que le spawn des mobs qui fonctionne.

    Link to comment
    Share on other sites

    Merci de ton aide, j'ai réussi :)

     

    Par contre, maintenant c'est Buildcraft qui ne fonctionne plus...tant pis x)

     

    Sinon ne connais tu pas des mods qui ajoutent de très sympathiques nouvelles possibilités, et en plus qui ne sont pas difficile à installer en smp ? x)

    Edited by Solaart
    Link to comment
    Share on other sites

    En truc sympa pour ceux qui aiment bâtir, tu as SuperSlopes qui ajoute tout un tas de nouveaux blocs (Pentes et coins en tout genre) et qui est compatible avec ItemCraft.

     

    Tu peux trouver une liste ici (Incomplète, il manque justement SuperSlopes et il manque aussi le Fancy Pack) des mods disponibles (Or mod compatibles ModLoaderMP) sur ce forum qui fait office de forum officiel pour le support autour d'Itemcraft. :)

    Link to comment
    Share on other sites

    Via Itemcraft, il est compatible. Il y avait une vieille version toute buguée qui datait de la 1.5 et qui était juste mise à jour pour être compatible jusqu'à il y a quelques semaines.

    Depuis, un mec a repris le portage du mod depuis zéro et il avance au fur et à mesure. De souvenirs, les mobs aquatiques spawnent désormais correctement et il est possible d'apprivoiser et monter les chevaux.

    Pour le reste, les mobs spawnent normalement mais à part les chevaux, ils ne peuvent pas encore être apprivoisés (Pour ceux avec lesquels c'est possible de le faire).

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    ×
    ×
    • Create New...