Jump to content
News ticker
  • Bienvenue sur le nouveau forum VeryGames
  • Welcome to the new VeryGames forum
  • VeryNews

    Probleme BigBrother


    Boyard

    Recommended Posts

    Bonjour, j'avait eu un probleme avec BigBrother, qui entrait en conflit avec permissions. J'ai donc rennommé Permissions.jar en aPermissions.jar. Maintenant, ils n'entrent plus en confli, mais quand je fait /bb stick 1 ou 2 , le stick apparait, avec les infos dans le tchat, mais quand je clique sur un bloc, rien ne se passe, même pas "No edits on this block"...

     

    Merci de votre aide !

     

    pour info, j'utilise une base de donnée SQLITE.

    Link to comment
    Share on other sites

    Fais un /plugin list et regarde si BigBrother apparait en rouge ou en vert. S'il apparait en rouge, c'est qu'il est inactif. Connecte toi au ftp et efface la base de donnée BigBrother puis fais un /rl et un /plugin list de nouveau. Si le nom n'apparaît toujours pas en vert donne moi ta liste de plugin, c'est tres certainement un conflit.

    Link to comment
    Share on other sites

    Hello,

     

    Je suis pas sur que la 1.7.1 soit compatible avec ta version de CraftBukkit.

    Utilise la version 1.10.1 sinon avec un base de donnée H2 (comme SQLite).

     

    La dernière version de BigBrother 1.11.0 nécessite une base de donnée MySQL obligatoirement.

     

    Cordialement,

    Link to comment
    Share on other sites

    Quand je dis qu'il est désactivé je veux dire par la qu'il entre probablement en conflit avec d'autres plugins. A mon avis la solution la plus simple pour résoudre ton problème est de désactiver l'ensemble de tes plugins en ne gardant que les plus essentiels, si tu ne constate aucun problèmes sur ces plugins tu commence a réactiver les autres plugins un par un de façon a circonscrire le problème.

    Link to comment
    Share on other sites

    alors, j'ai enlever tout mes plugins , sauf bigbrother, marche toujours pas, j'ai essayer en les enlevant tous sauf essentials et permissions , puis en enlevant permissions, puis essentials, puis plus rien (sauf BB) et ca marche toujours pas :/

     

    ---------- Post added at 16h07 ---------- Previous post was at 15h57 ----------

     

    up svp c'est asser urgent :(

    Link to comment
    Share on other sites

    Hum, si BB fonctionnait correctement auparavant, c'est peut-etre que ta base SQLite est corrompu.

    Renomme le fichier .db qui est dans le répertoire "/plugins/BigBrother/" (rajoute l'extension .old à la fin par exemple).

     

    Puis redémarre le serveur.

     

    Je retrouve pas de site avec la version 1.10 sous H2.

     

    Est-ce que tu as regardé ce qui est noté dans les logs de ton serveur au démarrage ?

    Link to comment
    Share on other sites

    Non, je vais regarder ca

     

    voila ce qui a écrit :

     

    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.

    java:213)

    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager

    .java:136)

    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:143)

    at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:110)

    at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur

    ationManager.java:51)

    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:133)

    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:337)

    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    16:13:57 [iNFO] [Permissions] (Yeti) was initialized.

    16:13:57 [iNFO] Preparing level "world"

    16:13:57 [iNFO] Preparing start region for level 0 (Seed: -4019584206927875547)

    16:13:58 [iNFO] Preparing start region for level 1 (Seed: 1107900113559202083)

    16:13:58 [iNFO] Preparing spawn area: 48%

    16:13:59 [iNFO] [Permissions] version [3.1.5] (Yeti) loaded

    16:13:59 [iNFO] [VanishNoPickup] 1.9.12 enabled.

    16:13:59 [iNFO] [iChat] Found Permissions (v3.1.5)

    16:13:59 [iNFO] iChat (v2.3.1) enabled

    16:13:59 [iNFO] WorldGuard: Permissions plugin detected! Using Permissions plugi

    n for permissions.

    16:13:59 [iNFO] WorldGuard: (world) Single session is enforced.

    16:13:59 [iNFO] WorldGuard: (world) TNT ignition is blocked.

    16:13:59 [iNFO] WorldGuard: (world) Lighters are PERMITTED.

    16:13:59 [iNFO] WorldGuard: (world) Lava fire is blocked.

    16:13:59 [iNFO] WorldGuard: (world) All fire spread is disabled.

    16:13:59 [iNFO] WorldGuard: Loaded configuration for world 'world"

    16:13:59 [iNFO] WorldGuard: (world_nether) Single session is enforced.

    16:13:59 [iNFO] WorldGuard: (world_nether) TNT ignition is PERMITTED.

    16:13:59 [iNFO] WorldGuard: (world_nether) Lighters are PERMITTED.

    16:13:59 [iNFO] WorldGuard: (world_nether) Lava fire is blocked.

    16:13:59 [iNFO] WorldGuard: (world_nether) Fire spread is UNRESTRICTED.

    16:13:59 [iNFO] WorldGuard: Loaded configuration for world 'world_nether"

    16:13:59 [iNFO] WorldGuard: 1 regions loaded for 'world'

    16:13:59 [iNFO] WorldGuard 5.0-alpha10 enabled.

    16:13:59 [iNFO] Lockette version 1.3.8 is being enabled! Yay! (Core version 1.

    0)

    16:13:59 [iNFO] Lockette: Detected craftbukkit build [1060] ok.

    16:13:59 [iNFO] Lockette: Linked to Permissions plugin version 3.1.5

    16:13:59 [iNFO] Lockette: Using ops file for admin permissions.

    16:13:59 [iNFO] Lockette: Ready to protect your containers.

    16:13:59 [iNFO] [AuthMe] Using flatfile as datasource!

    16:13:59 [iNFO] [AuthMe] Cache for registrations is enabled!

    16:13:59 [iNFO] [AuthMe] 528 registered players loaded in 0.067 seconds!

    16:13:59 [iNFO] [AuthMe] Version 0.79 is enabled!

    16:13:59 [iNFO] [MobDisguise] by desmin88 version 1.6 enabled.

    16:13:59 [iNFO] [MagicCarpet] MagicCarpet version 1.5.6 is enabled!

    16:13:59 [iNFO] [MagicCarpet] Take yourself wonder by wonder, using /magiccarpet

    or /mc.

    16:13:59 [iNFO] [MagicCarpet] Using Permissions.

    16:13:59 [iNFO] [blockBlockOP] BlockBlockOP version 1.2 has been enabled!

    16:13:59 [iNFO] MapMarkers version 0.3.2 enabled

    16:13:59 [iNFO] [bBROTHER] Building `bbdata` table...

    16:13:59 [iNFO] [bBROTHER] BBData SQLite Driver r1 loaded!

    16:13:59 [iNFO] [bBROTHER] Permissions enabled using: Permissions v3.1.5

    16:13:59 [WARNING] [bBROTHER] 'Help' isn't detected. No /help support

    16:13:59 [sEVERE] Error occurred while enabling BigBrother v1.7.1 (Is it up to d

    ate?): PLAYER_ITEM

    java.lang.NoSuchFieldError: PLAYER_ITEM

    at me.taylorkelly.bigbrother.BigBrother.registerEvents(BigBrother.java:1

    77)

    at me.taylorkelly.bigbrother.BigBrother.onEnable(BigBrother.java:151)

    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)

    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader

    .java:885)

    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage

    r.java:278)

    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:178)

    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:161

    )

    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:286)

    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:273)

    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:149)

    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:337)

    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    16:13:59 [iNFO] Stargate v.0.6.7-dev is enabled.

    16:13:59 [iNFO] [stargate] Loaded 1 gate layouts

    16:13:59 [iNFO] [stargate] {world} Loaded 5 stargates with 0 set as always-on

    16:13:59 [iNFO] [stargate] {world_nether} No stargates for world

    16:13:59 [iNFO] [stargate] Found Permissions (v3.1.5)

    16:13:59 [iNFO] [AutoMessage] version [1.5] loaded

    16:13:59 [iNFO] WorldEdit 4.6 enabled.

    16:13:59 [iNFO] WorldEdit: Permissions plugin detected! Using Permissions plugin

    for permissions.

    16:14:01 [iNFO] Loaded Essentials build 2.3.1 by Zenexer, ementalo, Aelux, Brett

    flan, KimKandor, snowleo, ceulemans and Xeology

    16:14:01 [iNFO] Loaded EssentialsSpawn build 2.3.1 by Zenexer, ementalo, Aelux,

    Brettflan, KimKandor, snowleo, ceulemans and Xeology

    16:14:01 [iNFO] Server permissions file permissions.yml is empty, ignoring it

    16:14:01 [iNFO] Done (0.405s)! For help, type "help" or "?"

    16:14:01 [iNFO] /109.9.35.109:60760 lost connection

    16:14:02 [iNFO] KingVG [/2.13.6.146:55297] logged in with entity id 107 at ([wor

    ld] -75.78094559825122, 76.0, 616.5580405040193)

    16:14:08 [iNFO] Boyard [/81.247.90.124:57324] logged in with entity id 150 at ([

    world] -36.90625, 31.0, 224.8125)

     

     

     

    je te laisse analyser :p BB va toujours pas apres avoir renommer :(

     

    ---------- Post added at 16h17 ---------- Previous post was at 16h12 ----------

     

    Je voit ca :

     

    16:13:59 [sEVERE] Error occurred while enabling BigBrother v1.7.1 (Is it up to d

    ate?): PLAYER_ITEM

    java.lang.NoSuchFieldError: PLAYER_ITEM

    at me.taylorkelly.bigbrother.BigBrother.registerEvent s(BigBrother.java:1

    77)

     

    C'est aps du a sa ?

    Edited by Boyard
    Link to comment
    Share on other sites

    pour le serveur oui je suis chez verygames, mais pour ce qui est SQL non j'ai rien

     

    ---------- Post added at 16h34 ---------- Previous post was at 16h24 ----------

     

    up :(

     

    ---------- Post added at 16h43 ---------- Previous post was at 16h34 ----------

     

    SVP c'est vraiment urgent !

    Link to comment
    Share on other sites

    Bonjour

     

    Les solutions les plus simples sont parfois les meilleurs.

     

    Supprime tout ce qui concerne BB, ensuite va sur ton panel Verygames, rends toi dans la partie "Maintenance" et clic sur "Mettre à jour le serveur et tous mes plugins" réinstalle BB

     

    Normalement ça devrait fonctionner

    Link to comment
    Share on other sites

    voila :

     

    17:18:26 [iNFO] [MagicCarpet] MagicCarpet version 1.5.6 is enabled!

    17:18:26 [iNFO] [MagicCarpet] Take yourself wonder by wonder, using /magiccarpet

    or /mc.

    17:18:26 [iNFO] [MagicCarpet] Using Permissions.

    17:18:26 [iNFO] [blockBlockOP] BlockBlockOP version 1.2 has been enabled!

    17:18:26 [iNFO] MapMarkers version 0.3.2 enabled

    17:18:26 [iNFO] [bBROTHER] BBData SQLite Driver r1 loaded!

    17:18:26 [iNFO] [bBROTHER] Permissions enabled using: Permissions v3.1.5

    17:18:26 [WARNING] [bBROTHER] 'Help' isn't detected. No /help support

    17:18:26 [sEVERE] Error occurred while enabling BigBrother v1.7.1 (Is it up to d

    ate?): PLAYER_ITEM

    java.lang.NoSuchFieldError: PLAYER_ITEM

    at me.taylorkelly.bigbrother.BigBrother.registerEvents(BigBrother.java:1

    77)

    at me.taylorkelly.bigbrother.BigBrother.onEnable(BigBrother.java:151)

    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)

    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader

    .java:885)

    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage

    r.java:278)

    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:178)

    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:161

    )

    at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:452)

    at com.earth2me.essentials.commands.Commandreloadall.run(Commandreloadal

    l.java:19)

    at com.earth2me.essentials.commands.EssentialsCommand.run(EssentialsComm

    and.java:60)

    at com.earth2me.essentials.commands.EssentialsCommand.run(EssentialsComm

    and.java:55)

    at com.earth2me.essentials.Essentials.onCommandEssentials(Essentials.jav

    a:450)

    at com.earth2me.essentials.Essentials.onCommand(Essentials.java:343)

    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)

    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:12

    9)

    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:3

    52)

    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.

    java:737)

    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:701)

    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:694)

    at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)

    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)

    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:89)

    at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java

    :478)

    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)

    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:454)

    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363)

    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    17:18:26 [iNFO] Stargate v.0.6.7-dev is enabled.

    17:18:26 [iNFO] [stargate] Loaded 1 gate layouts

    17:18:26 [iNFO] [stargate] {world} Loaded 5 stargates with 0 set as always-on

    17:18:26 [iNFO] [stargate] {world_nether} No stargates for world

    17:18:26 [iNFO] [stargate] Found Permissions (v3.1.5)

    17:18:26 [iNFO] [AutoMessage] version [1.5] loaded

    17:18:26 [iNFO] Spout 1.0.5.227 has been initialized

    17:18:26 [iNFO] WorldEdit 4.6 enabled.

    17:18:26 [iNFO] WorldEdit: Permissions plugin detected! Using Permissions plugin

    for permissions.

    17:18:27 [iNFO] Loaded Essentials build 2.3.1 by Zenexer, ementalo, Aelux, Brett

    flan, KimKandor, snowleo, ceulemans and Xeology

    17:18:27 [iNFO] Loaded EssentialsSpawn build 2.3.1 by Zenexer, ementalo, Aelux,

    Brettflan, KimKandor, snowleo, ceulemans and Xeology

    17:18:27 [iNFO] Server permissions file permissions.yml is empty, ignoring it

    17:18:28 [iNFO] Disconnecting Player [/2.13.6.146:55382]: Votre pseudo (Player)

    contient des caractere invalides ou est trop long!

    17:18:33 [iNFO] Ooonceererer lost connection: disconnect.quitting

    17:18:33 [iNFO] Connection reset

    17:18:33 [iNFO] Connection reset

    17:18:33 [iNFO] Boyard lost connection: disconnect.quitting

    17:18:34 [iNFO] Disconnecting Player [/2.13.6.146:55383]: Votre pseudo (Player)

    contient des caractere invalides ou est trop long!

    17:18:34 [iNFO] Ooonceererer [/109.9.35.109:61467] logged in with entity id 3540

    at ([world] -172.04255228038545, 65.0, 101.62314552312198)

    17:18:35 [iNFO] Boyard [/81.247.90.124:57899] logged in with entity id 3541 at (

    [world] 242.25, 85.0, 147.6875)

    17:18:36 [iNFO] elgasse lost connection: disconnect.quitting

    17:18:36 [iNFO] Connection reset

    17:18:38 [iNFO] [AuthMe] Player Boyard logged in!

    17:18:39 [iNFO] elgasse [/82.224.179.168:49846] logged in with entity id 3593 at

    ([world] -173.26268208100566, 64.0, 105.8760524845448)

    17:18:39 [iNFO] Ulquiorra lost connection: disconnect.quitting

    17:18:39 [iNFO] Connection reset

    17:18:40 [iNFO] [Admin] Boyard: re

    17:18:40 [iNFO] [AuthMe] Player Ooonceererer logged in!

    17:18:43 [iNFO] [AuthMe] Player elgasse logged in!

    17:18:54 [iNFO] [Maitre-Ingenieur] elgasse: prend tes fourniture

    17:18:55 [iNFO] KingVG [/2.13.6.146:55389] logged in with entity id 3594 at ([wo

    rld] 111.32555194715053, 76.0, 86.30000001192093)

    17:19:01 [iNFO] Connection reset

    17:19:01 [iNFO] Boyard lost connection: disconnect.quitting

    17:19:02 [iNFO] Boyard [/81.247.90.124:57902] logged in with entity id 3645 at (

    [world] 252.42255195432895, 83.0, 202.33279811914116)

    17:19:05 [iNFO] [AuthMe] Player Boyard logged in!

    17:19:07 [iNFO] [AuthMe] Player KingVG logged in!

    17:19:11 [iNFO] §9[PLAYER_COMMAND] Boyard: /help

    17:19:11 [iNFO] [Apprenti] KingVG: re

    17:19:22 [iNFO] [Maitre-Ingenieur] elgasse: mais les a la poubelle tes pomme

    Link to comment
    Share on other sites

    écoute, je vois dans tes logs que tu utilise Spout, je ne sais pas si ça a un rapport mais en tout cas il le met dans l'erreur :

     

    at org.getspout.spout.SpoutNetServerHandler.a(SpoutNe tServerHandler.java

    :478)

     

    et autre chose, je ne vois pas tout tes logs (prends plutôt sur le FTP) car je ne vois pas ta version Bukkit. Je m’aperçois que tu utilise BB version 1.7.1 alors que sous la version bukkit [1060] il faut utiliser BB version 1.11.0.

    Link to comment
    Share on other sites

    Maxi: je venait d'installer spout, mais jlai désinstaller jarrive pas ale config. j'ai craftbukkit 1060. et BB 1.11 nécessite une base de donnée mysql, ce que je n'ai pas.

     

    Diamater:

     

    - Downgrad de craftbukkit : Comment je peux faire ca ?

    - Installation de la snapshot de BB qui prends cette nouvelle variable en compte : http://ci.nexisonline.net:8080/job/B...r/Recommended/ : c'est la 1.11 ca non ?

    Link to comment
    Share on other sites

    Oui mais ton problème ne vient pas de la base de donnée mysql mais du fait que BB demande au serveur une variable PLAYER_ITEM or cette variable dans la nouvelle version de bukkit est PLAYER_INTERACT d'ou le kiproko entre ton bukkit et ton bigbrother. Soit tu passe a la nouvelle version de BB qui réclamera la bonne valeur soit tu passe a l'ancienne version de Bukkit. Enfin bref ^^

     

    EDIT : Ah en fait t'as édité après :p bah pour downgrader craftbukkit tu as juste as installer l'ancienne snapshot mais bon ça serait dommage, mieux vaut mettre la version patchée de BB non ? et je ne sais plus quelle est le num de version par contre mais c'est le lien que je t'ai donné

    Edited by Diameter
    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    ×
    ×
    • Create New...