Jump to content
News ticker
  • Bienvenue sur le nouveau forum VeryGames
  • Welcome to the new VeryGames forum
  • VeryNews

    Problème chargement son avec AMX


    kfgkill
     Share

    Recommended Posts

    Pas de majuscule dans le nom ou le répertoire ?

    Le son est bien sur le FTP du serveur ?

    Le plugin est bien installé ?

    Tu l'as bien modifié avant de le compiler ?

    Link to comment
    Share on other sites

    plugin installer mais marche po

     

    nan il ny a pas de majuscule

    oui je l'est modifier avant de le compiller

    oui il est present sur le ftp du serveur sous le meme nom est extention

     

    je te cite ma config du plugin

     

    • #include <amxmod>
      new const PLUGINNAME[] = "Musique d'Attente"
      new const VERSION[] = "1.0"
      new const AUTHOR[] = "kEnNy_"
       
      /*****************************************************************************************
      * *
      * Joue un mp3 en boucle durant la connexion. *
      * ========================================== *
      * *
      * *
      * Definir le chemin du son ci-dessous. *
      * Le répertoire de base étant "cstrike/sound", donc simplement *
      * definir "test/test.mp3" pour un mp3 situé dans cstrike/sound/test/test.mp3 *
      * *
      *****************************************************************************************/
       
      #define TheSound "test/connect.mp3"
       
      /*****************************************************************************************
      * *
      * Scripting by kEnNy *
      * *
      *****************************************************************************************/
       
       
       
      public client_connect(id) {
      client_cmd(id,"mp3 loop sound/%s", TheSound)
      return PLUGIN_CONTINUE
      }
       
      public client_putinserver(id) {
      client_cmd(id,"mp3 stop")
      return PLUGIN_CONTINUE
      }
       
      public plugin_precache() {
      precache_sound(TheSound)
      return PLUGIN_CONTINUE
      }
       
      public plugin_init() {
      register_plugin(PLUGINNAME, VERSION, AUTHOR)
      return PLUGIN_CONTINUE
      }

     

    mon plugin s'apelle " loading_mp3.amx " et il est placer dans cstrike/addons/amx/plugin

     

    mon son lui est dans cstrike/sound/test

    Link to comment
    Share on other sites

    Re: plugin installer mais marche po

     

    (...)

    #define TheSound "test/connect.mp3"

    (...)

    client_cmd(id,"mp3 loop sound/%s", TheSound)

    (...)

     

    Si tu confirmes qu'en tapant la commande suivante, le son est bien audible et que le plugin est bien activé, cela doit fonctionner.

    mp3 loop sound/test/connect.mp3

    Sans ça, je ne vois vraiment pas pourquoi cela ne marcherais pas.

    Link to comment
    Share on other sites

    • 4 weeks later...
    Guest serghai

    j'ai tout fait correctement :twisted: sur mon hlsw il me dit "[ 26] Musique d'Attente 1.0 kEnNy_ loading_mp3.amx running oui " mais quand je me conect au serv j'ai pas de son.??? j'ai verifier le volume de mp3 et je l'ai essayer aussi sur mon cs

    Link to comment
    Share on other sites

    j'ai tout fait correctement [...] mais quand je me conect au serv j'ai pas de son.?

     

    Si tu n'entends pas le son, c'est que qqpart, il doit y avoir qqch qui t'a échappé.

     

    - Télécharges-tu le son ?

    - Entends-tu le son si tu tape "mp3 loop sound/tonson.mp3" dans ta console ?

     

    Peut-on avoir ton IP pour tester ?

    Link to comment
    Share on other sites

    Guest serghai

    quand je tape mp3 loop sound/chanson.mp3 ma "musique je lai renomer chanson" y a aucun son. l'ip serv c 87.98.194.3:27030 serv 852 et quand je me conect il se dll pas

    :?

    Link to comment
    Share on other sites

    Guest serghai

    par contre sur mon ftp ds test y a un fichier qui c creer en plus du son donc y en a 2 "chanson.mp3.ztmp" et mon son format mplayeur "chanson.mp3"? est ce normal?

    Link to comment
    Share on other sites

    Salut,

     

     

    Je me suis connecté sur ton serveur, et j'ai bien téléchargé ta musique. Par contre, il est vrai que je ne l'ai pas entendu.

     

    Dans ma console, j'ai pu lire cette erreur :

    warning: MP3_InitStream(30, sound\test\chanson.mp3) failed

     

    Le fichier est bien au bon endroit, il est bien nommé, il n'y a aucune erreur de ce coté là, puisque je l'ai bien télécharger.

     

     

    L'erreur, mon cher serghai, viens de ton " chanson.mp3 ". Je ne sais pas comment tu l'as fait, ou où est-ce que tu l'as trouvé, mais ce fichier est tout bonnement illisible!!!

    Aucun de mes players n'arrivent à le lire, il n'est pas modifiable en tant que mp3, bref, il n'a de mp3 que le nom.

     

    Je te conseil de bien re-lire le tutorial en 1er page, surtout la 1er Etape, visiblement, tu l'as un peu zappée. Pense à ne pas garder le meme nom que ton MP3 illisible... Sinon, les joueurs qui l'auront déja téléchargé, ne prendrons pas le nouveau, sauf s'il a un autre nom.

     

     

    Sinon, les fichiers .ztmp sont normaux. C'est simplement une copie du fichier original, mais compressé. C'est le serveur qui compresse avant d'envoyer, et garde le fichier compressé (chanson.mp3.ztmp) pour ne pas avoir à compresser à nouveau pour l'envoyer au prochain client qui ne l'a pas.

    Link to comment
    Share on other sites

    Guest serghai

    c bien un mp3 mais c le format il est en 320kbps . il le faut obligatoirement en 128 ou moin ? et suis obliger de refaire tou a zero pour le changer?recreer mon pluing?

    Link to comment
    Share on other sites

    Aucun de mes players n'arrivent à le lire, il n'est pas modifiable en tant que mp3, bref, il n'a de mp3 que le nom.

     

    TON MP3 : Un MP3 Lisible :

     

     

     

    Ton fichier "chanson.mp3" serait un fichier MP3 de 320kbits qui fait 14,7Ko ???

    :lol: ! MDR ! :lol:

     

     

    Oui, refais tout, et cette fois :

    - utilise un vrai MP3.

    - lis la 1ere Etape.

    Si tu respectes ces 2 points ridicules, tout devrais aller pour le mieux.

    Link to comment
    Share on other sites

    Guest serghai

    bon je v le changer mais sur cs il marchais avec la premiere etape mp3 play sound/test/musique.mp3 je v tester avec un autre je te tien au courrant merci de ta patience

    Link to comment
    Share on other sites

    Guest serghai

    j'ai refait la manip et pareil une fois dll sur le ftp il est plus lisible par le lecteur et il dll que 15ko !!c plus un mp3 grrr sur mon disk je le lis correc tement en mp3 une fois dll le lesteur mplayeur le prend plus :twisted: y a un beug essai de te conect sur le serv !!

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...