Jump to content
News ticker
  • Bienvenue sur le nouveau forum VeryGames
  • Welcome to the new VeryGames forum
  • VeryNews

    Probleme map multi minecraft


    Pachiluck

    Recommended Posts

    Bonjours,

    Je vien demandé vorte aide car je ne sais plus quoi faire ^^ J'ai un serveur minecraft Vanillia en 1.7.2 et depuis qu'elle que temps les chunk sur les qu'elle nous sommes instalé lague..

    Je m'explique sur le chunk de ma masion aucun soucis jeux fluide et tout mais deque je passe sur les chunk d'acoté je passe a 0-2 fps et sa ce refixe une fois que j'en sort il y a 5 chunk affecté et pas au même endrois mais dans les environ :s Je ne comprend pas d'ou cella peux venir car aucun gros systeme redstone y sont installé pas de ferme a mob qui pourais faire monté les entité ou quoi que ce sois. J'ai déja envoié un ticket au suport verygame et il on passé un script pour détècté les chunk corompus ou entité mais la non plus ca na rien donné

    Je m'en remet donc a vous.

    Si qu'elle qu'un a déja eu ce probleme et qu'il a une solution je suis preneur :)

    Merci a vous et bonne fin de journée/soirée :)

    Link to comment
    Share on other sites

    C'est un des souci de Minecraft cette histoire de baisse de FPS dont il est difficile voire impossible d'en trouver la cause...

    J'ai moi même un souci au spawn depuis quelques mois (mais moindre, ça reste jouables mais les petites configs tombent à 10-15 FPS) et malgré des heures de recherches et de tests, je n'ai pas réussi à résoudre le souci.

    Cependant, dans de tels cas ils faut vérifier la quantité d'entités présentes (via touche F3) sachant que la quantité normale se situe entre 10 et 100 entités. Les entités comptent les mobs, les Minecarts, les cadres (item frame), les tableaux... tu as la liste complète ici: http://minecraft-fr.gamepedia.com/Entit%C3%A9s

    J'ai eu des souci avec les item frame car pas mal de membres classaient leurs salle des coffres en utilisant que ces cadres. Or ils font parti des entités qui font le plus ramer le jeu. A savoir qu'un cadre avec un objet dedans compte pour 2 entités donc ça va vite!

    Les systèmes redstone en boucle (les horloges par exemple) posent aussi problème et c'est encore pire pour ceux qui utilisent des minecart en mouvement perpétuel.

    Les fermes automatiques, très prisées par les membres sont une horreur pour les FPS, surtout si les joueurs ont la bonne idée de les faire dans la même zone (genre le spawn^^). A proscrire complètement dans ce genre de lieux fréquentés.

     

    L'une de 1ère mesure à prendre, c'est de supprimer tous les mobs via une commande afin de vérifier si le souci ne vient pas d'un surnombre. J'ai eu le souci avec un membre qui avait enfermé 2 villageois dans une pièce de 3m² pas loin du spawn: ils se sont reproduis jusqu'à atteindre 600 villageois! Du coup on est tombé à 2-3 FPS avec de gros freeze et on arrêtait pas de se faire éjecter du serveur. Bref quelques exemples quoi. Pour remédier à ce genre de problème, je ne peux parler que des commandes de Essentials car je ne connais que lui pour ça, mais si tu l'as sur ton serveur (ou installe le pour l'occaz') tu devrais tenter ces commandes dans les zones concernées:

    /butcher 400 (tue tous les mobs hostiles dans un rayon de 400 blocs)

    /butcher -a 400 (tue tous les mobs pacifiques...)

    /butcher -n 400 (tue tous les villageois...)

     

    Perso je met 400 quand on ne trouve pas l'origine du souci, au moins on est sûr de nettoyer la zone, mais tu peux tenter 100 ou moins.

     

    Ensuite, si certains ont d'autres suggestions, je suis moi-même preneur car il y a dé-fois où cette perte de FPS est absolument incompréhensible (du moins pour moi), comme à mon spawn...

     

    Bonne chance en tous cas ;-)

    Link to comment
    Share on other sites

    Salut a toi :) et merci pour cette réponse trés précise ;)

    Je pense avoir résolu mon soucis en passent sur la version bukkit ^^ Mais je n'ai jaimais utilisé de pluggin ni rien donc je vais bien voire mais je n'ai plus de soucis ( pour l'instent car on a remarque qu'il ne ramait pas a tout les coup x) )

    Je vais essyé d'instalé un ou deux plugin conseillé et voire si il revienne :)

    Bonne soirée a toi

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    ×
    ×
    • Create New...